Jump to content

Infraestrutura Colocar imagens Shop-In-Game Rep++


Recommended Posts

Diga em poucas palavras a base utilizada (Nome do servidor ou nome do website).

Ex. TFS 1.3;

Base: 

Gesior AAC Master

 

Qual erro está surgindo/O que você procura?

Não estou conseguindo colocar as imagens no shop in game, ja segui diversos tutoriais na internet .

Antes de eu trocar a imagem ele fica com um simbolo de interrogação, depois quando troco ele muda a imagem para aquele circulo de roload.

 

Ja baixei outras imagens  e verifiquei o tamanho esta em 32x32 e continua

 

sempre reinicio o ot tambem nao adianta

 

Você tem o código disponível? Se tiver publique-o aqui:

 

 

Você tem alguma imagem que possa auxiliar no problema? Se sim, coloque-a aqui.

antes.JPG

depois.JPG

Link to post
Share on other sites

  • 1 month later...
Em 10/10/2018 em 13:54, Rafael1839 disse:

Diga em poucas palavras a base utilizada (Nome do servidor ou nome do website).

Ex. TFS 1.3;

Base: 

Gesior AAC Master

 

Qual erro está surgindo/O que você procura?

Não estou conseguindo colocar as imagens no shop in game, ja segui diversos tutoriais na internet .

Antes de eu trocar a imagem ele fica com um simbolo de interrogação, depois quando troco ele muda a imagem para aquele circulo de roload.

 

Ja baixei outras imagens  e verifiquei o tamanho esta em 32x32 e continua

 

sempre reinicio o ot tambem nao adianta

 

Você tem o código disponível? Se tiver publique-o aqui:



 

 

Você tem alguma imagem que possa auxiliar no problema? Se sim, coloque-a aqui.

antes.JPG

depois.JPG

 

cara consegui resolver.

 

1 - no config.lua vc coloca a coin ImgaesUrl assim - "http://localhost/store/" ou o caminho onde elas estao no meu caso por usar a porta 8090 ficou assim " http://localhost:8090/store/" e vc tbm pode usar seu IP do servidor no lugar de localhost.

 

2 -  ainda no config lua vc deixa "CoinPacketSize = 25"

 

3 - agora na pasta do seu servido vc vai em data\modules\scripts\gamestore e abre o arquivo gamestore.lua, nele vc verifica o nome de todos os itens que estarão na loja e as imagens 

image.thumb.png.9d6c32a9ad39e5eda4e84028af955555.png

 

4 agora dentro do seu Xampp ou outro servidor q vc usar pro site, vc entra na pasta Htdocs ou WWW e procura pela pasta Store se nao tiver cria uma, dentro da pasta store eu encontrei duas pastas 32 e 64 e um arquivo .Htaccess

 

A- dentro das pastas as imagens devem estar com o tamanho certo e com fundo transparente e com os nome iguais aos da pasta GameStore no seu OTServer

 

B - e nesse arquivo .Htacees  precisa estar  assim image.png.d654f020408027a6d3cc39e78cd48c91.png. essa pequena palavra ALLOW é que tava impedindo o sistema de buscar as imagens pelo LINK URL no CONFIG.LUA

 

5 -  depois de fazer tudo isso vc precisa limpar o cache use a Tecla WINDOW+R e escreva %appdata% e procure pela pasta do tibia, APAGUE A PASTA TIBIACACHE outra maneira de limpar é ir na pasta do client e dentro da pasta STOREIMAGES apagar essas duas pastas image.png.6af72f132a7083f81aca06f937979b4b.png

 

Isso foi tudo que eu consegui reunir de informaçoes pra conseguir resolver esse problema, espero ajudar. VLW

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Winona
      .Qual servidor ou website você utiliza como base? 
       
      Qual o motivo deste tópico? 
      sempre que compilo um novo executavel sempre da esse erro
      Está surgindo algum erro? Se sim coloque-o aqui. 
       
      Você tem o código disponível? Se tiver publique-o aqui: 
      src.rar
       
      Você tem alguma imagem que possa auxiliar no problema? Se sim, coloque-a aqui. 
       
    • By Maper1
      .Qual servidor ou website você utiliza como base? 
      otserverbr
      Qual o motivo deste tópico? 
      fechando sozinho
      Está surgindo algum erro? Se sim coloque-o aqui. 
       
      Você tem o código disponível? Se tiver publique-o aqui: 
         
      Você tem alguma imagem que possa auxiliar no problema? Se sim, coloque-a aqui. 
       
    • By Ember
      .Qual servidor ou website você utiliza como base? 
      Poke X Black
      Qual o motivo deste tópico? 
       
      Está surgindo algum erro? Se sim coloque-o aqui. 
       
      Você tem o código disponível? Se tiver publique-o aqui: 
         
      Você tem alguma imagem que possa auxiliar no problema? Se sim, coloque-a aqui. 
       


    • By studiopimenta
      Boa Noite TK, tudo certo com vocês?
       
      Recebi um servidor completo: Mapa+Server.... o problema é que quando eu tento entrar na conta do Account Manager em jogo com o acesso do SQLiteStudio está dando senha invalida.
      De uma olhada na area do config.lua
       
      sqlType = "sqlite" sqlHost = "localhost" sqlPort = 3306 sqlUser = "root" sqlPass = "123456789" sqlDatabase = "warnew" sqlFile = "warnew.s3db" sqlKeepAlive = 0 mysqlReadTimeout = 10 mysqlWriteTimeout = 10 encryptionType = "sha1" Alguma idéia de como resolver???
    • By Pedro quinca
      Qual melhor source para usar para um projeto sério? ou seja uma source sem erros de segmentação, sem traps e o máximo optimizada possível.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

Confirmação de Termo