Jump to content

Recommended Posts

Boa noite galera, baixei esse gesior aqui ,

e estou tentando instalar ele mais nao consigo da esse erro:

 

Error: Unable to connect to MySQL. Debugging errno: 1045 Debugging error: Access denied for user 'root'@'localhost' (using password: YES)

 

image.thumb.png.47210ef519a562a158467e81f157d3b6.png

 

Todas as senhas estão de acordo, config.php e config.lua

 

Obg desde já ! 

Link to post
Share on other sites

Bom dia, entre na pasta do seu servidor (no meu caso é o xampp) e procuro pelo arquivo config.inc.php que geralmente fica na pasta do phpMyAdmin, abra este arquivo e procure pela linha $cfg['Servers'][$i]['password'] ao achar essa variável você altera ela para a senha que você colocou no seu banco de dados.

 

Espero ter ajudado.

Link to post
Share on other sites

8 horas atrás, MatteusDeli disse:

Bom dia, entre na pasta do seu servidor (no meu caso é o xampp) e procuro pelo arquivo config.inc.php que geralmente fica na pasta do phpMyAdmin, abra este arquivo e procure pela linha $cfg['Servers'][$i]['password'] ao achar essa variável você altera ela para a senha que você colocou no seu banco de dados.

 

Espero ter ajudado.


MySQL Error Message: Access denied for user 'root'@'localhost' (using password: YES)

> ERROR: Couldn't estabilish connection to SQL database!

image.thumb.png.fae20910cb32617b002238dce3e1b8b9.png

 

Nao consegui  achar o config.inc.php no meu ubuntu 16.04...

o erro ainda persiste, eu tenho outro servidor em outra vps isso intefere algo quando uso o 127.0.0.1 em localhost?

Obg desde ja

Edited by Heitorzera13 (see edit history)
Link to post
Share on other sites

1 hora atrás, Heitorzera13 disse:


MySQL Error Message: Access denied for user 'root'@'localhost' (using password: YES)

> ERROR: Couldn't estabilish connection to SQL database!

image.thumb.png.fae20910cb32617b002238dce3e1b8b9.png

 

Nao consegui  achar o config.inc.php no meu ubuntu 16.04...

o erro ainda persiste, eu tenho outro servidor em outra vps isso intefere algo quando uso o 127.0.0.1 em localhost?

Obg desde ja

 

Você ta usando qual tipo de servidor para rodar o site? O xampp, mamp ou lampp?

Link to post
Share on other sites

O que está acontecendo é um problema de privilegio no banco de dados. Tente abrir o arquivo config.php na pasta do site html/config/config.php e procure por esta linha (ela está lá pro final do arquivo) $SQLlink = mysqli_connect("localhost", "root", "123456", "baiak"); Aonde está com a cor verde é a password de acesso ao banco de dados.

 

Algumas soluções: 

 

1° Tente remover a senha que está em verde, deixando ela vazia, apenas com as aspas "";

$SQLlink = mysqli_connect("localhost", "root", "", "baiak");

 

2° Caso você deixando em branco e a conexão não estabeleça, você terá que checar se o seu banco de dados está com alguma senha de acesso, caso esteja coloque ela aonde está em verde dentro das aspas.

$SQLlink = mysqli_connect("localhost", "root", "SUA_SENHA_AQUI", "baiak");

 

Link to post
Share on other sites

Em 13/11/2020 em 12:28, MatteusDeli disse:

O que está acontecendo é um problema de privilegio no banco de dados. Tente abrir o arquivo config.php na pasta do site html/config/config.php e procure por esta linha (ela está lá pro final do arquivo) $SQLlink = mysqli_connect("localhost", "root", "123456", "baiak"); Aonde está com a cor verde é a password de acesso ao banco de dados.

 

Algumas soluções: 

 

1° Tente remover a senha que está em verde, deixando ela vazia, apenas com as aspas "";


$SQLlink = mysqli_connect("localhost", "root", "", "baiak");

 

2° Caso você deixando em branco e a conexão não estabeleça, você terá que checar se o seu banco de dados está com alguma senha de acesso, caso esteja coloque ela aonde está em verde dentro das aspas.


$SQLlink = mysqli_connect("localhost", "root", "SUA_SENHA_AQUI", "baiak");

 

Obrigado irmão !
[RESOLVIDO]

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By lemongie
      Salve galerinha, alguem sabe alguma função pra capturar o nome do item no gesior?
       
       

       
    • By Bruce Pereira
      Galera, estou com um projeto aqui e coloquei um looktype na vocation, quando está male funciona normal, mas quando é female fica com outfit female e looktype nao funciona.
      desativei as outfit mas so desativou o outfit para male. portante quero tirar a opção female, se alguem puder me ajudar agradeço muito.
      accountmanagement.php
    • By cesarfilho55
      Qual o motivo deste tópico? 
       "Nenhum dos seus personagens tem o level requerido para criar uma guilda. (500)"
      Mesmo com os personagens nesse nível, o site não deixa criar guild.
       
       
      Agradeço a turma que ajudar!
      (sou meio leigo em criar tópico, caso esteja no lugar errado, me explica).
       
    • By Luanmax21
      Ola tenho um site de ot server e sistema de lost account funcionava perfeitamente depois parou de funcionar, e aparece no site da gmail que um sistema menos seguro tenta realizar login na conta ai ele e bloqueado alguem sabe resolver isso?
       
    • By Endless
      Olá senhores, desenvolvi um Plugin que vai dar um "tchann" extra em seu servidor rsrsrs.

      Sobre o Sistema:

      Este é o Sistema de Auction, convertido para MyAAC.
      Testado para 0.3.6 / 0.4
      Para alterar qualquer configuração do sistema, você pode acessar: system/pages/auction.php
       
      Demo:

       
       
      Instalação:

      Baixe o plugin: auction-system.zip
      Vá até o Painel de Administração, selecione a aba 'Plugins' e selecione auction-system.zip, clique em upload.
      Mova o arquivo => auctionsystem.lua <= para `data/talkactions/scripts`
      Adicione a tag `<talkaction words="!offer_gold" event="script" value="auctionsystem.lua"/>` em talkactions.xml de seu servidor

      Pronto, instalado XD!!

      PS:
      -> O sistema foi testado e não apresentou problemas, porém se vierem a encontrar falhas, favor reportar para que eu possa manter o tópico atualizado/corrigido.
      -> Eu faço correções no sistema caso esteja errado, mas não faço adaptações pro seu servidor. Caso queira variações do sistema, favor enviar seu pedido no discord da Academia de Programação, ou em meu discord privado: Endless#5410

      Créditos:
      @Tottin Por desenvolver junto comigo a lógica.
      Créditos pela script base: https://tibiaking.com/forums/topic/34172-trade-off-shop-offline/?tab=comments#comment-192640
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

Confirmação de Termo