Jump to content
Close

italo1071

Member
  • Content Count

    14
  • Joined

  • Last visited

About italo1071

  • Rank
    Baker

Profile Information

  • Gender
    Masculino
  • Localization
    Brasil
  • I am
    Tibiano
  • My character
    Vidaloka
  • Favorite OTServ
    NTO
  • Bot preferred
    NTO

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. BASE: (ela foi editada mais foi baseada no othire) Bom o meu erro é o seguinte eu tou compilando a source eu compilei deu tudo certo quando eu abro o executavel compilado acontece o seguinte independente de no config.lua esteja setada para usar mysql ela sempre busca por SQLite eu já adicionei as FLAGS na hora de compilar do mysql (_USE_MYSQL_) eu não sei porque ela sempre busca SQLite e não MYSQL que eu quero usar já revi toda configuração já recompilei umas 10x e nada Tutorial que eu sigo: Compiling tutorial for Windows using Microsoft Visual C++ - A modified Open Tibia Server You need Visual C++ 2010 Express Edition - http://filehippo.com/download_visualc_2010_express_edition/ Download Sources - https://github.com/Qwizer/rlmap740x Steps Download source code Create new project click File -> New -> Project... select Visual C++ -> General -> Empty Project set 'Name' for your project (I'll name it "server") set 'Location' for your project (It's "D:\projects" for me) leave 'Solution name' same as 'Name' ("server") 'Create directory' for solution should be checked Adding files go to 'Location\Name\Solution name' of your project (D:\projects\server\server), and copy there all content of source folder in Solution Explorer right click on Header Files -> Add -> Existing item..., right click on Sort by -> Type, select all header files (.h extension), don't forget about the msvc.h and workarounds.h (from 'compiler' folder) in Solution Explorer right click on Source Files -> Add -> Existing Item..., select all source files (.cpp extension) Setting project up go to (in menubar) Project -> Properties in the top left corner, set Configuration to 'Release' in tree widget on the left, go to Configuration Properties (you should be there anyway) General, Platform Toolset should be 'v100', Character Set should be 'Use Multi-Byte Character Set ' , rest leave as default C/C++ General click Additional Include Directories, drop down button shall appear, click on it, and in new window add following directories: libraries\inc\boost libraries\inc\libiconv libraries\inc\libxml libraries\inc\lua libraries\inc\mpir libraries\inc\mysql libraries\inc\sqlite Multi-processor compilation (optional), you can set it to 'Yes', that will speed compilation Preprocessor Preprocessor definitions, click on it, choose edit, and add: __USE_OTPCH__ __USE_MYSQL__ __SKULLSYSTEM__ __OLD_GUILD_SYSTEM__ __GUILDWARSLUARELOAD__ __ENABLE_SERVER_DIAGNOSTIC__ Precompiled Headers set Precompiled Header to 'Use' set Precompiled Header File to 'otpch.h' Linker General Additional Library Directories, click dropdown button, edit and add: libraries\lib (entire path, as exemple D:\otserv\projects\libraries\lib) Input Additional Dependencies, click dropdown button, edit and add: libmysql.lib libxml2.lib lua5.1.lib mpir.lib sqlite3.lib dbghelp.lib we are done here, press Ok in Solution Explorer -> Source Files, right click on otpch.cpp -> Properties make sure Configuration (top left) is 'Release' go to Configuration Properties -> C/C++ -> Precompiled Headers set Precompiled Header to 'Create' set Precompiled Header File to 'otpch.h' press Ok Compilation in the toolbar (top center) change configuration from 'Debug' to 'Release' click Build -> Build Solution
  2. Bom gente tou com um servidor 7.72 aqui Estou com um erro o server inicia normal tudo carrega certinho mais quando eu vou logar apareço em uma ilha estranha que no site ta escrita na town assim: "Sample town" eu ja tentei mudar na sourcr onde cria o char por exemplo mudei a id da town coloquei 3 por exemplo ae eu salvo eu fui criar um char pra ver se saiu da ilha esquisita e bugada mais ae qnd eu vou logar a client simplesmente crasha ela sai.. isso acontece sempre.. meu serv: 7.72 , alguem poderia me ajudar? Simplesmente não sei o que fazer
  3. Oi pessoal vou começar a desenvolver um ot de tibiame já tenho toda a engine pronta preciso de ajuda de programadores e game designers
  4. Alguem que tenha a source do tibia antigo 6.5 ou - que isso poderia compartilha?... obrigado desde já .
  5. mano o RME map editor não ta prestando eu seleciono a pasta da client q vc me enviou so que o erro continua diz que não foi possivel localizar tibia.dat and tibia.spr
  6. ok só que ate agora não achei nenhum download da client 10.98 pramim baixar :|
  7. blz mais qual os dados da ACC que ja tem na db pramim logar pra testar??
  8. ok como fasso pra jogar ?? onde baixo a client para rodar esse servidor. se puder me enviar os dados das accs que ja tem na db pramim logar
  9. mano e normal demorar para ler o mapa no Oganza.exe?? o meu ta demorando d+
  10. Alguem poderia compilar um servidor pramim? Download: http://www.mediafire.com/file/wije7y934x7b4fx/Servidor.rar Scan: https://www.virustotal.com/pt/file/bda76b25967a287189adf510a5254f85e505f639519c3aed5f9c84fd9729a46a/analysis/1488030050/ Tópico de quem publicou o servidor: Alguem ajuda ae!
  11. você ja tem uma base?? sobre esse assunto.

Open Tibia Server

Quer aprender a criar seu próprio servidor de Tibia? Então está no lugar certo, aqui você encontrará milhares de tutorias, scripts, códigos, mapas e utilitários para que você possa fazer o seu próprio servidor de Tibia partindo do zero.

Redes Sociais

Anuncie no Tibia King

Precisa de mais visibilidade em seus projetos? Quer publicidade para o seu servidor? Anuncie no Tibia King e faça sua divulgação, possuímos centenas de acessos simultâneos e milhares diários, com certeza será a sua solução! A publicação do seu anuncio é instantânea!

×
×
  • Create New...